Hawkinz

Low frame rate issues and game optimization

508 posts in this topic

30 minutes ago, Gribabas said:

I think that many fanboys just ignore the fact that Price is full and wont change depending of optimization in future. As well as minimal reqs. If someone is fooled by developers and all this EA stuff why do u protect them? Enjoy the game, but don't support fake marketing

Looks like you just got into the game today, and have not followed the devs a tad bit for the past weeks. They where as clear and transparent as it get when it comes to the state of the game, the current performence on lower end hardware and their plans for optimizing the game.

The game going into early access means, it is not a finshed product, but if you still want to play it you can pay 30 bucks to do so. I am pretty sure nobody held a gun to your head and forced you to buy the game. You might want to refund, and look at the game in about six months when it leaves early access.

The only one fooling people is you, with your random false accusations, running around the forum pretending the devs want to silence you for posting that they are not transparent when it comes to the the "real system requirements". Its not people being "fan boys" when they dont agree with you....

1 person likes this

Share this post


Link to post
Share on other sites
3 minutes ago, Donutbox #TrumpISOurPresident! said:

So does anyone have an solution to the problem other than putting graphics on very low? Cause that doesn't quite budge :/

The solution would be patience, and waiting for optimization patches.

This is not a justification, just a statement: Also, to be honest people who go for wins play the game on all low settings anyway in order to get an advantage. So even People with a Titan X, 1080 or me with a 1070 play on low.

 

Share this post


Link to post
Share on other sites
20 minutes ago, blackdude0 said:

The solution would be patience, and waiting for optimization patches.

This is not a justification, just a statement: Also, to be honest people who go for wins play the game on all low settings anyway in order to get an advantage. So even People with a Titan X, 1080 or me with a 1070 play on low.

 

Okay, hope the game gets optimized soon. I'm not giving up on the game because I really really like it. I managed to get to the top 10 even with 20 fps! It was super fun and exhilarating !

Share this post


Link to post
Share on other sites

Posted (edited)

They did almost no optimization so far. Early access will be the period, in which they do that.

Make sure to follow the patch notes and dev blog in order to see the progress.

Edited by blackdude0

Share this post


Link to post
Share on other sites
3 hours ago, nexonas said:

Rx 480 and i5 6600k here

my settings: 60-100fps

 

How do you get better fps than streamers that have a Titan X and 1,000$ Intel CPU?

Share this post


Link to post
Share on other sites

You have to consider your resolution too, i have about 35 fps but i play in 2560x1440. 

-1070 Strix 2050mgz

-i7 860 

-8Go (1600 CL7)

-SSD 850evo

The I7860 is pretty old but run at 50%, the 1070 is at 98% and i have between 28/38 fps at 1440k in low except the textures in high.

About the same fps than Star Citizen in very high and compared to this game it's a movie. 

 

 

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Cream said:

You have to consider your resolution too, i have about 35 fps but i play in 2560x1440. 

-1070 Strix 2050mgz

-i7 860 

-8Go (1600 CL7)

-SSD 850evo

The I7860 is pretty old but run at 50%, the 1070 is at 98% and i have between 28/38 fps at 1440k in low except the textures in high.

About the same fps than Star Citizen in very high and compared to this game it's a movie. 

 

 

 

 

Star Citizen has been in development for 6 years 3x the budget and about 5x the man power.

Share this post


Link to post
Share on other sites

Posted (edited)

i5 4690k overclocked to 4.2ghz, gtx 1060 6gb, 16 gigs of ram, and not getting over 60 fps. My processor is over 90% the whole time playing the game on all low. :(

Edited by silo

Share this post


Link to post
Share on other sites

Posted (edited)

The game is running smooth over 100fps most of the time for me. Sometimes I get FPS drops and rubberbanding, but that's normal under the circumstances.

1. When you release a game it's easy to get overwhelmed unless you have servers with as strong a backbone as Valve, Dice or similar companies.

2. PC is complicated to optimize for, that's where consoles have the advantage. New games almost always go through this, you're playing early access, a paid beta, not a finished game.

@Hawkinz I would really appreciate it if you pinned a topic with fixes to optimization we can do on our end as they become available. I think it would give you less complaints while you work out the kinks in the game.

Edited by AtotehZ
1 person likes this

Share this post


Link to post
Share on other sites
Just now, AtotehZ said:

@Hawkinz I would really appreciate it if you pinned a topic with fixes to optimization we can do on our end as they become available. I think it would give you less complaints while you work out the kinks in the game.

Good idea, I'll amend the first post in this thread with some tips soon. Although, there isn't much you can do to improve FPS currently unfortunately. That will change in the future.

Share this post


Link to post
Share on other sites
Just now, Hawkinz said:

Good idea, I'll amend the first post in this thread with some tips soon. Although, there isn't much you can do to improve FPS currently unfortunately. That will change in the future.

There's the usual stuff like forcing vsync off and not allowing more than 1 prerendered image at a time. I'd bet there's also things in the unrela engine cfg's that can be changed if you know where the game is performance heavy.

Share this post


Link to post
Share on other sites
1 minute ago, AtotehZ said:

There's the usual stuff like forcing vsync off and not allowing more than 1 prerendered image at a time.

Good point! Also decreases input lag as well.

Share this post


Link to post
Share on other sites

i7-4790K/Intel Z97 mobo

GTX1080
16GB RAM

SSD with 100GB free
3 monitors, but playing the game in windowed mode 1920x1080 because it's not happy using all three. 

I turned everything down to High, the game defaulted at ultra. It didn't seem to help much. 

Nvidia doesn't even recognize the game as utilizing 3D. I can't get an FPS counter to show up in game. Turn it on, change corners of the screen, turn it off, try again etc.  That being said, I can't tell you an actual frame rate, but it isn't high. I can tell you that input lag is horrendous. It feels like I'm a walking helicopter and I'm constantly arresting a moment. I get massive frame drops and teleporting as well. Mouse sensitivity changes from room to room, picking up items or opening doors (just any interaction in general) takes multiple tries. I think it might even be listening to my mic and waiting for me to swear before it works.  

I realize the game is early access and it's going to have bugs on the first day.

I'm open to suggestions. 

Share this post


Link to post
Share on other sites

@RumDomRum I wouldn't run it in 3d(if you're referring to with 3d glasses), but that's up to you. Aside from that, picking stuff being bugged is server related, nothing you can do there.

What I did myself was this:
Go to nvidia control panel -> Application 3d settings -> Game specific settings -> Add the game -> set Vsync to off and max pre-rendered to 1
In game I set to fullscreen(not windowed) and post processing and foliage to "Very Low" and everything else where I wanted it.
I'm not saying my way is the correct one, it's just something I'm used to doing in other multiplayer survival games.

The bug with sensitivity is weird. Did you change sensitivity in controls without changing all of them to where you want them? There are 7 sliders.

Share this post


Link to post
Share on other sites
2 minutes ago, AtotehZ said:

@RumDomRum I wouldn't run it in 3d(if you're referring to with 3d glasses), but that's up to you. Aside from that, picking stuff being bugged is server related, nothing you can do there.

What I did myself was this:
Go to nvidia control panel -> Application 3d settings -> Game specific settings -> Add the game -> set Vsync to off and max pre-rendered to 1
In game I set to fullscreen(not windowed) and post processing and foliage to "Very Low" and everything else where I wanted it.
I'm not saying my way is the correct one, it's just something I'm used to doing in other multiplayer survival games.

The bug with sensitivity is weird. Did you change sensitivity in controls without changing all of them to where you want them? There are 7 sliders.

@AtotehZ
That brings me to another issue, the sliders! 
they bounce around while trying to change them, quite frustrating. 

I already had pre-rendered frames to 1, but I just did V-sync. 

I have to choose windowed or it goes to all three screens. Even if I do "fullscreen-windowed" and have 1920x1080 selected, it still forces to all three. With all three screens active, the Vertical FOV is so reduced, I can only see the head of my character and a few feet above him. 

Thanks for the help. I'll try those and see if it improves anything. 

Share this post


Link to post
Share on other sites

Posted (edited)

@RumDomRum You can fix the fullscreen thing by going to windows settings and making center one the primary screen and the other ones extended desktops. Right now you probably have it to stretched desktop.

You might be able to do it in nvidia control panel as well, but try windows first.

Edited by AtotehZ
1 person likes this

Share this post


Link to post
Share on other sites

I have a rendering issue and 40 fps.

I have my settings all on very low and 1280x700 res.

My specs are:

gtx 750ti 4gb

fx 4350

8gb ram.

I know that my proccessoe ia old and lower then minimum.

Will it help if i upgrade my proccessor?

 

20170323_232600.jpg

Share this post


Link to post
Share on other sites

Posted (edited)

Yup having this same issue at start of matches.  Also having issues during rain matches with big time frame drops making them difficult to play.  I am using the same exact settings I used during beta and never had these problems.  Will play with my graphic settings in the mean time...

Update, after playing with settings with no results, I reinstalled the game onto my SSD drive instead of the regular hard drive.  Haven't had any issues with buildings rendering since.  Also, experiencing less massive frame drops.  Note, this was only occurring for me while I was running obs & a browser in the background.  Otherwise it ran ok when background programs were closed on the HHD.   Just found it startling as I was able to stream with no issues with it on the HHD during beta (only change to my system since then was applying the 378.92 nvida driver update).

Well anyway, until the optimization fixes come, maybe putting the game on a SSD drive will help alleviate the frames issue for some people. 

PC Specs:

Windows 10

Intel i5-4670K CPU @ 3.40GHz 

8192MB RAM

GeForce GTX 1070 

1920x1080 res

 

Edited by ImmortanGamer

Share this post


Link to post
Share on other sites

holy fuck, this thread is hilarious :D

you should all keep in mind that the current game is an EARLY ACCESS version of it. they do this to fix and optimize the game with the help of the community playing the game in this early status.

give them the time to optimize and calm down brothers

 

1 person likes this

Share this post


Link to post
Share on other sites
13 hours ago, Fingazz said:

This game is a scam. FX 8350 8GB ram, rx480 and also get 20fps. 
Updated drivers, installed on SSD, I want my money back to be honest. SHHHH#@(T game

You're quite welcome to issue a refund request on Steam. There is no scam here, the game is in early access and is yet to be optimized for all systems.

The vast majority of developing effort in the next 6 months will be focused on optimization and making the game run as smooth as possible, for as many people as possible.

Here is a short developer blog post pertaining to optimization:

http://playbattlegrounds.com/news/64.pu

Share this post


Link to post
Share on other sites

Posted (edited)

This is my experience from the 1st weekend of beta to early access.

My specs:

i7-4790K / GTX 970 OC / 16Gb ram / Win 7 64bits / Resolution size 1920x1080

I use only this command: -USEALLAVAILABLECORES

1st weekend at the 4th weekend (the game is installed from the HDD) :

I get anywhere from 40fps to 100fps depending on where i am on the map and where i'm looking.

[ScalabilityGroups]
sg.ResolutionQuality=100.000000
sg.ViewDistanceQuality=2
sg.AntiAliasingQuality=1
sg.ShadowQuality=0
sg.PostProcessQuality=0
sg.TextureQuality=2
sg.EffectsQuality=0
sg.FoliageQuality=0

[/Script/TslGame.TslGameUserSettings]
ScreenScale=100.000000
Gamma=50.000000

Now EA (the game is installed from the SSD) :

I get anywhere from 60fps to 120fps depending on where I am on the map and where I'm looking.

[ScalabilityGroups]
sg.ResolutionQuality=100.000000
sg.ViewDistanceQuality=3
sg.AntiAliasingQuality=1
sg.ShadowQuality=0
sg.PostProcessQuality=1
sg.TextureQuality=3
sg.EffectsQuality=2
sg.FoliageQuality=0

[/Script/TslGame.TslGameUserSettings]
ScreenScale=100.000000
Gamma=50.000000

I have increased the graphics settings and I have even more fps and mostly the game is much more beautiful and more fluid. This time I installed the game on my SSD and i do not know if it is the fact of having made a new installation on the SSD or if the developers have improved the performances but the game is much more fluid than the beta and much more beautiful now.

I can still increase the graphic settings without losing fluidity but for now I stay like that because I have a few drops of fps from time to time especially in large buildings.

Edited by Dam

Share this post


Link to post
Share on other sites

i7 6700k 4.00ghz

Nvidia 1070 MSI

16GB DDR4 3000mhz

No more than 60fps and sometimes when i look around i get framedrops.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now