Caesar of Roma

Connection/Steam/Launch Issues: A Comprehensive Guide

599 posts in this topic

1 minute ago, Hamooter said:

I have only installed this game today but having the same problem as this guy, it shows it is running for about 10secs and then stops, no loading screen or anything.

 

I have validated the files but unsure of how do all the other things mentioned in this thread, please can some help me.....

I think its an issue that the devs haven't noticed yet. They haven't responded to me, and I just assumed it would be fixed in a few hours.

I haven't found ANY solution to this specific problem, that we both share. I tried a few more solutions for other issues, and none of them worked.

I hope this is something they fix soon, because I want to play, and even bought a new GPU, just to play this game, and now....I won't be buying a new cpu, since this is the only game I play, that utilizes a CPU this much.

Share this post


Link to post
Share on other sites
8 hours ago, milquetoast123 said:

How many millions do they need to make to have a customer service team? Is it uncommon to have customer service, before you make $100 million or something?

No support chat, phone number, forum support... nothing...

I just want to play this fantastic game, but nobody will answer my plea.

We live in hope!!!!!

Maybe the Moderator of this thread knows something? Caesar of Roma

Share this post


Link to post
Share on other sites
On ‎5‎/‎1‎/‎2017 at 3:44 PM, milquetoast123 said:

I think its an issue that the devs haven't noticed yet. They haven't responded to me, and I just assumed it would be fixed in a few hours.

I haven't found ANY solution to this specific problem, that we both share. I tried a few more solutions for other issues, and none of them worked.

I hope this is something they fix soon, because I want to play, and even bought a new GPU, just to play this game, and now....I won't be buying a new cpu, since this is the only game I play, that utilizes a CPU this much.

Exact same issue for me. luckily after checking windows updates again today I was blessed to find update 1073 which I believe to be what fixed my issue.

 

Share this post


Link to post
Share on other sites

I bought the game today. 

 

I can search for a game and get put into a game, but when everyone is running around punching people and it is counting down to "Game Starting in 60....59...58" my game freezes and I cant do anything. If I close the game, TsiGame is still running and I cant attempt to reopen the game until I restart. I have tried moving all graphics to LOW, playing in windowed mode, Verifying Game Cache, and reinstalling multiple times.

 

I have a GeForce GTX 690 running on the latest drivers released 5/4.

Share this post


Link to post
Share on other sites

TERRIBLE connection and disconnects. I STILL haven't been able to play and it's been months.

Does anyone have ANY idea what ports we need to open? I'm so fed up of troubleshooting over and over. Every update that drops I'll try again in hopes of a fix for connectivity but nope. This is the only game I own that is unplayable due to poor servers.

I've tried opening old ports listed but still no juice after. Have they changed?

Share this post


Link to post
Share on other sites

FIXED IT!

For me, none of the methods listed on the front page worked, or those suggested by the last few pages.

My issue occured after applying the new big Win10 update and changing GPUs (but keeping same nvidia drivers)

To fix I repaired both VC Redist installs - 2015 and 2013. I think it was the 2013 one that did it as that prompted me for a reboot then the game worked!

For me the exe was in \Steam\steamapps\common\PUBG\_CommonRedist\vcredist\2013\

Just execute, repair, reboot.

Share this post


Link to post
Share on other sites
On 2017-5-1 at 4:39 PM, Hamooter said:

I have only installed this game today but having the same problem as this guy, it shows it is running for about 10secs and then stops, no loading screen or anything.

 

I have validated the files but unsure of how do all the other things mentioned in this thread, please can some help me.....

Same thing happening to me, and for what I can see, it's useless to try and get devs to check up on the issue. I just bought the game and I'm ready to request a refund, because it's ridiculous that this isn't working at the moment.

Share this post


Link to post
Share on other sites

I'm stuck at the LOADING front.battlegroundsgame.com/index.html screen. The only solution that worked for me was to change the DNS server; thanks to that I was able to play a few hours yesterday, but today I'm stuck on the same screen again!!!

It must be network related if it's this random...

Share this post


Link to post
Share on other sites

Guys get this shared round and give it a try for it will solve so many of your issues! SO LUCKY I CAME ACROSS IT! Hit up the link watch the video and let me know if it works! thank you guys and hopefully be seeing you in the battlegrounds soon!

The bug I had was the loading screen coming up with loading in the top left however it never actually loaded my player in, still played music and had menu background, Hit up the fix if this is your problem! 

Thank you :D PEACE! 

Share this post


Link to post
Share on other sites

I made tool pack for people that might have problems, you can check it out here: 

The latest download is at the bottom of the topic.

Will work on most computers, i made most of the support automated.

Share this post


Link to post
Share on other sites

Posted (edited)

I can lunch the game, edit a character, start a matchmaking game.

i get into the black screen with the player unknow battle ground...  i can hear pple, i can hear gun fight, i hear the plane and the parachute drop.

But the game the black screen with the player unknow battle ground is always there.

It's like the game never stop loading but i know i can play under the black screen because i hear every thing.

And the i got connection time out.

what is wrong ??  i don't see many thread on that issue.

Edited by Psychomyself

Share this post


Link to post
Share on other sites

I've done everything but whenever i press play and battleye starts up but then crashes and says "battleye launcher has stopped working." 

Share this post


Link to post
Share on other sites

my problem is,i get to the lobby,click play,then i get the logo screen,then its stuck,wait about 25min pop back to lobby,i done all the reinstall,install,verity the game,firewall,window defender,admin but still the same

 

need help please!

Share this post


Link to post
Share on other sites
On 5/14/2017 at 10:49 PM, Psychomyself said:

I can lunch the game, edit a character, start a matchmaking game.

i get into the black screen with the player unknow battle ground...  i can hear pple, i can hear gun fight, i hear the plane and the parachute drop.

But the game the black screen with the player unknow battle ground is always there.

It's like the game never stop loading but i know i can play under the black screen because i hear every thing.

And the i got connection time out.

what is wrong ??  i don't see many thread on that issue.

same here,have you solve it yet by now?

Share this post


Link to post
Share on other sites

PLZ  help me with this problem!  The first game of the day was good  but it cant start again without VPN and my VPN is unstable 。 plz help me 。 I live in japan  the problem start in May

Snap1.png

Share this post


Link to post
Share on other sites

None of these helped my issue. After I hit "Play" and the game finds a server, I can't connect in. Ends up saying "Connection timeout. 2.2.47 -". Please, help me find a solution for this! This started happening about a month ago and I still haven't found a fix! And unfortunately, I can't get a refund because I have 55 hours played! HELP!

Share this post


Link to post
Share on other sites

Hi I just got the game today, and it won't launch. All I keep getting is this (see: photo attached). It doesn't even show on my Task Manager that it's running, or it ran previously. The game just won't load. Please help!

error.png

Share this post


Link to post
Share on other sites

Bug Description:

Game will not Launch

""the application was unable to start correctly (0xc0000022). click ok to close the application""

Date Seen:
Every time I play.

Troubleshooting Attempted:

  • Reinstall 2013 and 2015 visual c++
  • Reinstalled game
  • Reinstalled drivers
  • Disabled windows defender
  • Disabled windows firewall

Other Information:
8GB ram
GTX 970 ti
i5 2500k

Windows 10

Share this post


Link to post
Share on other sites
On 5/11/2017 at 7:30 AM, RadoriK said:

I'm stuck at the LOADING front.battlegroundsgame.com/index.html screen. The only solution that worked for me was to change the DNS server; thanks to that I was able to play a few hours yesterday, but today I'm stuck on the same screen again!!!

It must be network related if it's this random...

have you fixed the problem? Im also experiencing the same problem

Share this post


Link to post
Share on other sites

Bug Description:

Game will not Launch

Task manager will show 0% about TSLgame.exe .

Every time i want to open the game, i need to repeat following steps for at least 5 times. 1. the game is not launching, 2. kill the task , 3. repeat.

Date Seen:
Every time I play.

Troubleshooting Attempted:

  • Repair and reinstall 2013 and 2015 visual c++
  • Reinstalled game
  • Reinstalled steam
  • Reinstalled drivers
  • Completed all the window update
  • Disabled windows defender
  • Disabled windows firewall

Other Information:
16GB ram
R9 270
athlon x4 740

Windows 7

If i enter a game, i can play the game smoothly.

taskmanager.jpg

Edited by YY

Share this post


Link to post
Share on other sites

So it's been several months and I still can't play this game... I play hundreds of online games and this is the ONLY title I cannot play. The ports needed to be open would help but I still don't get any responses......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now