Jump to content
llithix

White screen after start menu

PUBG_RoboDanjal

Hi everyone, if you're having issues with the error below please let us know the following information: 

Which Xbox are you using?
Wired or wireless connection?

Message added by PUBG_RoboDanjal

Recommended Posts

Have you tried doing a power cycle/hard restart on the Xbox? (Holding down the power button)

Have you tried signing out and signing in into your Xbox Acc?

Share this post


Link to post
Share on other sites

Could be a server overload since it seems to be happening to more people. Seeing reports on reddit too.

All we can do is wait and not freak out.

Edited by Squibeel

Share this post


Link to post
Share on other sites
1 minuto atrás, DIEnamicDYnasty disse:

Hopefully they got someone working the holidays

 

Yes they do. No worries there.

Share this post


Link to post
Share on other sites

Temporary.  I got the white screen again this evening, hard reset my Xbox, still didn't work.  But reset my router, again, and pubg loaded up fine. If just turning off your router and modem doesn't help,  you might have to factory reset them.  That's what I had to do to finally get pubg to work the last time. Cause just turning them off then back on didn't work the first few times I tried it.  

 To factory reset your modem and router,  there's a tiny button on the back or side of the router or modem.  You have to get a pen or something small to get to the button,  and hold it in for 10 seconds while the router or modem is on.  

If that doesn't work, you'll probably need to get in touch with your isp and see if they can help with the connection problem.  

Share this post


Link to post
Share on other sites

On Xbox I keep getting the message account already exists immediately after I sign in, I just bought the game today. I’ve already reset the console multiple times. Can anyone help me fix this please?

1B3053A2-E028-416A-9F4C-1B428F0CF3CC.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

Bought it yesterday, I was about to try it for the first time today with my friend. But the same thing just keeps happening. There goes $30 down the drain.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×