Jump to content
MedicWoolums

L/R Mouse buttons periodically don't work

Recommended Posts

Bug Description:
My left and right mouse buttons periodically do not work. The bug is not constant and unpredictable and typically disables my left and right mouse buttons for roughly 5 seconds (inconsistent durations). The mouse otherwise works fine, I can turn and do whatever I want. If I am zoomed in (right-clicked) when the bug strikes I cannot zoom out. It is not a lag as my clicks do not register later, they are simply void. This bug seems to happen mostly when I am attempting to kill other players, it has got me killed many times as my first or second shot will register and then there will be a period where I cannot shoot at all. I originally thought it was the mouse (despite it working perfect in other games) so I bought a new one, same issue. 

Date Seen:
Last time seen was today (5/17/17) however it has been an issue for me since day 1.

Server: 
Not on test server. Normal NA server.

Troubleshooting Attempted:
I have bought a new mouse. I have made sure all drivers are up to date. I have made sure the game is up to date. I have disabled "enhanced pointer precision." I have toyed with numerous mouse settings.

Other Information:
Nothing I can do to work around as far as I can tell. I play on a very nice gaming laptop and I've tried using the mouse pad while the bug is active and it still does not appear to work.

Launch Options:
I haven't tried any command options.

System Specifications:
see attached

system ss.png

display ss.png

Share this post


Link to post
Share on other sites
18 hours ago, MedicWoolums said:

Bug Description:
My left and right mouse buttons periodically do not work. The bug is not constant and unpredictable and typically disables my left and right mouse buttons for roughly 5 seconds (inconsistent durations). The mouse otherwise works fine, I can turn and do whatever I want. If I am zoomed in (right-clicked) when the bug strikes I cannot zoom out. It is not a lag as my clicks do not register later, they are simply void. This bug seems to happen mostly when I am attempting to kill other players, it has got me killed many times as my first or second shot will register and then there will be a period where I cannot shoot at all. I originally thought it was the mouse (despite it working perfect in other games) so I bought a new one, same issue. 

Date Seen:
Last time seen was today (5/17/17) however it has been an issue for me since day 1.

Server: 
Not on test server. Normal NA server.

Troubleshooting Attempted:
I have bought a new mouse. I have made sure all drivers are up to date. I have made sure the game is up to date. I have disabled "enhanced pointer precision." I have toyed with numerous mouse settings.

Other Information:
Nothing I can do to work around as far as I can tell. I play on a very nice gaming laptop and I've tried using the mouse pad while the bug is active and it still does not appear to work.

Launch Options:
I haven't tried any command options.

System Specifications:
see attached

system ss.png

display ss.png

Well that is odd if you can still use the mouse to move but you are unable to click.... It kind of sounds like the software with the mouse doesn't like the game. Next time it happens can you alt+tab out and see if it works then? 

  • Like 1

Share this post


Link to post
Share on other sites
Colinoo    1
Posted (edited)

I have the exact same issue and I also tried 2 different mouses. It only happens in this game and I tried to press alt+tab and it works then.

Edited by Colinoo

Share this post


Link to post
Share on other sites
17 hours ago, Caesar of Roma said:

Well that is odd if you can still use the mouse to move but you are unable to click.... It kind of sounds like the software with the mouse doesn't like the game. Next time it happens can you alt+tab out and see if it works then? 

I have not alt-tabbed, but I have shift tabbed and steam's menu responds to the mouse clicks. This issue is solely in this game. Both my mouses work 100% of the time outside of this game. 

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Colinoo said:

I have the exact same issue and I also tried 2 different mouses. It only happens in this game and I tried to press alt+tab and it works then.

Sorry to hear that but good to know I'm not the only one. Really hope there is a fix for this as sometimes it makes the game borderline unplayable.

  • Like 1

Share this post


Link to post
Share on other sites
Colinoo    1
1 hour ago, MedicWoolums said:

Sorry to hear that but good to know I'm not the only one. Really hope there is a fix for this as sometimes it makes the game borderline unplayable.

I agree, sometimes we're in a very important battle against another squad and I think I have a free kill and I let my teammates down every single times because mid fight this happens.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Colinoo said:

I agree, sometimes we're in a very important battle against another squad and I think I have a free kill and I let my teammates down every single times because mid fight this happens.

Yep I'm right there with you. It's unbelievably frustrating trying to explain to everyone why I couldn't shoot someone, especially when they are spectating me. My most recent game I was #3 and was killed in the final shootout, I fired one time and then it locks up, essentially just letting them know where I am. Needless to say that ended in a loss and a rage quit 

Share this post


Link to post
Share on other sites

Colinoo could you post your specs here? Interested to see what similarities we have. Might help narrow down where the problem could be.

Share this post


Link to post
Share on other sites
Colinoo    1
1 hour ago, MedicWoolums said:

Colinoo could you post your specs here? Interested to see what similarities we have. Might help narrow down where the problem could be.

I will do so tomorrow mate. And literally the same thing happened to me today..

Share this post


Link to post
Share on other sites
Hausgeist    1
Posted (edited)

I have the same Problem,try the same things and it still comes back.Its a Problem of PUBG alone,all other Games dont have this ever.

I have a Razor Mouse,whats the Mouse of the other people with this Problem?

Maybe its the Razor driver i guess,pleas tell me what Mouse you got.So maybe we can tell Razor to fix the Driver if all with this Problem got a Razor Mouse.

Sorry for my bad english,its not my mother language..

Edited by Hausgeist
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Hausgeist said:

I have the same Problem,try the same things and it still comes back.Its a Problem of PUBG alone,all other Games dont have this ever.

I have a Razor Mouse,whats the Mouse of the other people with this Problem?

Maybe its the Razor driver i guess,pleas tell me what Mouse you got.So maybe we can tell Razor to fix the Driver if all with this Problem got a Razor Mouse.

Sorry for my bad english,its not my mother language..

The mouse I just bought is the Logitech G502, one that was recommended by a friend who also plays PUBG with the G502 with no issues.

 

I can confidently say the mouse has nothing to do with the issue.

Share this post


Link to post
Share on other sites
22 hours ago, MedicWoolums said:

Mods, do you have any suggestions? 

Hey Medic, I've forwarded the issue onto the team for further review. :-) 

  • Like 2

Share this post


Link to post
Share on other sites
Colinoo    1
14 hours ago, Caesar of Roma said:

Hey Medic, I've forwarded the issue onto the team for further review. :-) 

when will you possibly know more?

 

thanks in advance

Share this post


Link to post
Share on other sites
20 hours ago, Caesar of Roma said:

Hey Medic, I've forwarded the issue onto the team for further review. :-) 

Thank you very much!!

Share this post


Link to post
Share on other sites
Drothe14    2

Just to raise awareness on this matter, I'm having the same issue. so frustrating. Just been in a game, pulled off a really good kill only to be wiped out 5 minutes later because I cant shoot my gun. It isn't only the L and R, my thumb keys are also unresponsive.

Using Logitech G402, totally fine out of games and in others.

Fix for this would be greatly appreciated.

  • Like 1

Share this post


Link to post
Share on other sites
noah741    3

Bug Description:
At random times my left and right click will not register. I will have to left/right click anywhere between 5-15 times before it registers. If it is the left click that I am having to click multiple times, it will "catch up" and suddenly shoot a bunch of bullets all at once. Sometimes I am stuck aiming down sight and right clicking will NOT get me out of it.

Date Seen:
I experience this every time I play.

Server: 
NOT ON TEST SERVER. 

Troubleshooting Attempted:I can  press 'X' to change weapons and it will get me out of ADS immediately. I never experience this "non-registering" effect on any keyboard shortcuts. I have tried different USB ports, re-installing the game, verifying game cache, and using a different mouse. 

A part of me is wondering if it is my ISP. My internet speed and bandwidth are NOT the issue as I have 140mbps down and 25mbps up. However, I've had issues with my ISP before. 

I JUST played a game on EU servers, and while I never had a missed left click shot, I had a couple instances where my right click got stuck. So it would seem based off that one game alone that it could be region based. (I live in Florida)

Other Information:
I am using a desktop PC. 

Launch Options:
NONE

System Specifications:

i7 4770k 3.5GHz

16GB ram

ASRock z97 extreme 6

GTX 1070

250GB samsung SSD

  • Like 1

Share this post


Link to post
Share on other sites
noah741    3

*UPDATE*

I have made some major progress in pinpointing what is going on. Whenever I turn my character to the right, my left and right mouse buttons will NOT register at all. My keyboard will still work, but not my mouse. I can spin to the right for an infinite amount of time and the mouse buttons will never register. However, as soon as I look left, even by .000001 degree, the mouse buttons will work again. This malfunction occurs on 2 different mice. I recorded a video of what I am describing and have linked it. 

 

 

Share this post


Link to post
Share on other sites
noah741    3

*FIXED*

I changed my resolution from Windowed Fullscreen to regular Fullscreen and it fixed the issue. Hope I can help someone out that has this same issue

  • Like 2

Share this post


Link to post
Share on other sites
On 5/23/2017 at 11:50 AM, noah741 said:

*UPDATE*

I have made some major progress in pinpointing what is going on. Whenever I turn my character to the right, my left and right mouse buttons will NOT register at all. My keyboard will still work, but not my mouse. I can spin to the right for an infinite amount of time and the mouse buttons will never register. However, as soon as I look left, even by .000001 degree, the mouse buttons will work again. This malfunction occurs on 2 different mice. I recorded a video of what I am describing and have linked it. 

 

 

Sounds like a similar but different issue. This doesn't work for me but I'm glad you fixed yours. I'll have to toy with the full screen settings next time I'm on.

Share this post


Link to post
Share on other sites
Falcon91    7

This issue sounds more like something with the internal coding of the game rather than on your end, unless let me ask.

 

During these time when this happens does your game suddenly catch back up? If it does it could even be a network issue, or the fact they host their servers on AWS which is meant for websites and voice servers.

Share this post


Link to post
Share on other sites
Caveman    0

I hope this can get sorted it's killing me when I have been waiting for someone then when they finally get there they shoot me because buttons don't work this also happens to my space bar sometimes 

Share this post


Link to post
Share on other sites

So in an attempt to try and fix the problem as a few here have said works, I have broken my game entirely. I noticed my settings were on Fullscreen (Windowed) so I changed it to just fullscreen. Now my mouse pointer is no where remotely close to where the game thinks I'm clicking (pointer will be way to the right of where the clicks register.) I can't even change the setting back because the settings button is in the top right hand corner of the menu screen and that area is now unclickable (when I click the settings button with my pointer I actually end up clicking 'statistics.' Trying to change the setting back in game did not work either. I managed to click 'reset' and 'default' but neither change my game back to Fullscreen (windowed). 

 

Please help =( 

Share this post


Link to post
Share on other sites

×