Jump to content
caseyy89

AMD System needs help

Recommended Posts

Aiiiiiiiii    88

@caseyy89 

Then you just have to wait for the 25th patch and maybe it will help a little. But it might not be enough as the CPU is not very powerful anymore :( You could squeeze out more fps by overclocking the CPU, but only if you are or know someone who is experienced in overclocking and have sufficient cooling to cool down the overclocked CPU. Like a high end air cooler or watercooling.

Share this post


Link to post
Share on other sites
T.Bag    8
Posted (edited)

Hey folks

I've been running game with numerous tweaks and launch commands. Recently I decided to wipe my *.ini files in WindowsNoEditor. Before that, I had around 120 fps, settings: fullscreen, 1080p, medium AA, PP, effects, shadows, foliage on very low and textures, view very high, screen scale on 100. 120 FPS, so what's the problem, you would ask. The same as everyone - apart from lags (be honest - EU servers are unplayable now for me), I had massive stuttering while using 4x-8x scopes, while steam was showing me that I have 45-48 fps. After *.ini wipe (I keep "-malloc=system -USEALLAVAILABLECORES -HIGH" in steam launch commands), I decided to let my game handle itself - what I mean is that in Radeon Settings I reverted PUBG profile to default state and turning off Shader Caches. I have set up shadows, effects, foliage to medium, and AA to ultra and now I have 80 FPS in menu, 45 on  island, 30 on plane (stable FPS, no stuttering) and 48-50 in cities, open ground - 60. I also changed my pagefile from auto to 2939-8000 on HDD, the game is on SSD. Still, I notice that the game has massive problems when it has to load assets - when new players join lobby or more people appear in the area as the circle gets smaller. The results are better, but far from satisfying, considering that I still get stutters (less painful, but still...). I have also noticed that when the game loads player models, CPU usage goes to 100%, otherwise it's 60-70%.

I hope that my feedback will help someone, but I also want to ask you a question - is there anything else I can do to minimize stuttering? I know it's early access, but hey, maybe there is something I am still missing (apart from patches...)?

RIG:
Windows 10 Pro 64-bit (upgraded from Win 8.1)
Intel Core I5-6500 CPU @ 3.2 Ghz (4 cores)
16 gb RAM (2133 MHz)
Radeon RX480 HD (8 Gb of VRAM)
Realtek Soundboard (built in)
MSI Z170A PC Mate Motherboard
Sandisk SDSSDP064G (used for Windows and PUBG)
XMP is turned on.
ALL drivers and BIOS up to date.
This is the ONLY game I have problems with.

OT: But as for EU servers state right now I would like to get a refund if it was possible :c But that game is to addictive, 51h of gameplay as for now...

Edited by T.Bag

Share this post


Link to post
Share on other sites
Aiiiiiiiii    88
8 minutes ago, T.Bag said:

Hey folks

I've been running game with numerous tweaks and launch commands. Recently I decided to wipe my *.ini files in WindowsNoEditor. Before that, I had around 120 fps, settings: fullscreen, 1080p, medium AA, PP, effects, shadows, foliage on very low and textures, view very high, screen scale on 100. 120 FPS, so what's the problem, you would ask. The same as everyone - apart from lags (be honest - EU servers are unplayable now for me), I had massive stuttering while using 4x-8x scopes, while steam was showing me that I have 45-48 fps. After *.ini wipe (I keep "-malloc=system -USEALLAVAILABLECORES -HIGH" in steam launch commands), I decided to let my game handle itself - what I mean is that in Radeon Settings I reverted PUBG profile to default state and turning off Shader Caches. I have set up shadows, effects, foliage to medium, and AA to ultra and now I have 80 FPS in menu, 45 on  island, 30 on plane (stable FPS, no stuttering) and 48-50 in cities, open ground - 60. I also changed my pagefile from auto to 2939-8000 on HDD, the game is on SSD. Still, I notice that the game has massive problems when it has to load assets - when new players join lobby or more people appear in the area as the circle gets smaller. The results are better, but far from satisfying, considering that I still get stutters (less painful, but still...). I have also noticed that when the game loads player models, CPU usage goes to 100%, otherwise it's 60-70%.

I hope that my feedback will help someone, but I also want to ask you a question - is there anything else I can do to minimize stuttering? I know it's early access, but hey, maybe there is something I am still missing (apart from patches...)?

RIG:
Windows 10 Pro 64-bit (upgraded from Win 8.1)
Intel Core I5-6500 CPU @ 3.2 Ghz (4 cores)
16 gb RAM (2133 MHz)
Radeon RX480 HD (8 Gb of VRAM)
Realtek Soundboard (built in)
MSI Z170A PC Mate Motherboard
Sandisk SDSSDP064G (used for Windows and PUBG)
XMP is turned on.
ALL drivers and BIOS up to date.
This is the ONLY game I have problems with.

OT: But as for EU servers state right now I would like to get a refund if it was possible :c But that game is to addictive, 51h of gameplay as for now...

Hi!

Looks like you've been busy troubleshooting. Good good :) Are you using Afterburner by any chance? You could use that or hwmonitor to monitor the cpu and gpu usage during gameplay and see if either of those spike during the stutter. Do you experience the same stutter or worse if you have very low on all graphic settings? What resolution are you playing at?

Have you tried to run the game without any injected overlays like relive or steam? Have you tried rolling back the GPU driver. I've been using 17.4.2. It's been working spot on for me and gives great performance.

It's unlikely that the pagefile is causing havok when you have 16Gb Ram, but you could try to move it on SSD and give that a shot. Just make it something like 4096-4096 so it's not changing size on the fly.

Share this post


Link to post
Share on other sites
T.Bag    8

Thanks for a reply!

No, I am not using Afterburner right now, but that's what I am intending to do on my next plays, because CPU behaviour in this game is really concerning me right now. Resolution is 1920x1080. No overlays, but I even tried streaming the game with OBS Studio - it went pretty well, no noticeable FPS drops.
As for settings and stutter - It's a mix between medium and ultra, because I noticed that fps are more stable and drops are a little bit better.

As for drivers, good point, I'll try to make a clean install of 17.4.2. Indeed, it looks like some issues are on the driver-game line, as you can read in my feedback.

As for pagefile - changing it caused my game to crash on startup 1-2 times, but after that the game launched as normal. As for moving to SSD - I doubt that pagefile and the game on same drive would be optimal, but I am going to try it now.

As I've noted, before rollback and changing driver settings, with INCREASING in-game settings I went from 110 fps to 80 in menu (on island it's now 45 vs 60).
With current driver (17.5.1.), Shader Cache should be to blame. Also, in my case teselation mode and optimalization of surfaces blahblahblah have to be default, as changing them causes flickering of water in-game.

Let's see what I will get with afterburner recording and older drivers, I am really curious :)

Share this post


Link to post
Share on other sites
T.Bag    8

Quick sample (drop in crowded area near Mylta, short gameplay ended by retarded shootout outside bunkers)
4096-4096 pagefile on SSD with the game
Rollbacked drivers to 17.4.2. (CLEAN install), shader cache on, everything else untouched
Much less flickering with shader cache enabled, no difference in fps between these settings now.
I was messing around with settings during the game, but last setup was H/H/M/U/M/VL/U, fullscreen.

FPS 45-70, stuttering is noticeable if I shake my view violently or enter new area and the game has to load assets (rendering more detailed trees etc.)
What concerns me is the difference between pagefile usage and RAM usage. It's like 'screw your RAM, I like your pagefile MOAR'

afterburner.png.238ef7762c934b4b4bb8c9b23b13e72a.png

Share this post


Link to post
Share on other sites
T.Bag    8

Another sample this time made it to top10 (Ghillie suit is op imho), without pagefile. Sadly, I couldn't get a scope to test if stutters would occur (I am playing as the 'sniper' in squad mode, so there it is most frustrating), but now it seems like stuttering during running etc. is only caused by desyncs from time to time.

I am still open to any further ideas and I also hope that my feedback will help anyone with similar problems.

afterburner2.png

Share this post


Link to post
Share on other sites
Aiiiiiiiii    88

@T.Bag

Seems like your CPU is maxing out on the first picture causing the GPU utilization to drop. Any other changes you made on the second run? Your components are acting completely different on it.

Share this post


Link to post
Share on other sites
relax    0

Hi, you can try undervolting and increasing powerlimit in wattman. Works well for my rx480. Also seriously forget about any launch parameters in steam. I'm sure there's guides how to undervolt amd cards on YouTube.

Share this post


Link to post
Share on other sites
T.Bag    8

@Aiiiiiiiii

The only change I made was disabling pagefile completely.

Share this post


Link to post
Share on other sites
Orchero    2
19 hours ago, caseyy89 said:

Hello, 

i cant seem to get the game running good, i tried everything that i could find online so far

this is what im working with 

 

OS: Windows 10 Home 64-bit
CPU: AMD FX-8350 8-Core @ 4.2ghz
RAM: 16.0 GB Dual-Channel DDR3 RAM
Motherboard: MSI 970A-G43 Plus (MS-7974)
GPU: ATI AMD Radeon R9 390 8GB
Display: 24" Acer GN246HL 144Hz

i cannot get over 40 frames and i have constant stuttering

i tried with and without launch options, fiddled around with the settings ingame, tried to optimize the ini files

admin mode , priority to high, fullscreen etc. etc. 

 

maybe there is something that i dont know but i would love to get the game running in a playable way 

 

Hello mate!

I got this spec:

Fx 6350

8 GB Ram

R9 270x 2 GB

And a full hd 144 hz monitor

Everything is on low for me and I play the game in 50 fps . My pc is worse than yours so you shouldn't have problems . 

Now what i've done to improve the gameplay: Basicly a BIOS update helped me ALOT -> Improved the fps and the stability of the game . Now everything renders quickly enough for me to enjoy the game. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×