Jump to content
NiNJAWALK

3 resolution options to choose, horrible FPS

Recommended Posts

HI guys i would like to desperately ask You for help. I have been having issues with this game regardless very decent specs. Multiple rebooting used to be the solution for last couple of days but it seems to no longer work . Whenever i launch the game, the black screen with BLUEHOLE logo loads up full screen, then the window shrinks once i get to main menu. I attach a screenshot explaining it all. I have only 3 basic resolution options to chose (800*600, 1024*720, 1920*1080), besides that the game seems to work as normal, but if i get into the game, my fps is horrible and game feels veeery rough - i get like 19 fps.  The lower resolution i set, the smaller the window gets, outside of window stays unchanged and i can use desktop as normal without ALT TABBING the game although its set to full screen as you can see. Please guys, help as I am desperately trying to find a solution. 

Steps already taken:
Complete Windows reinstall
Game re-downloaded
All drivers updated
Power plan set to high performance
Deleted AMD Crimson Relive
Deleted AMD Raptr


My specs:
CPU: Intel i7 6700K SKYLAKE 4.00 GHZ
GPU: AMD MSI RADEON R9 390 series 8 GDDR5
MB: MSI z170a m5 gaming
RAM: Corsair Predator 16GB (8x2)
SSD1 System: Kingston HyperX 240 GB
SSD2 Games/Programs: Kingston HyperX 480 GB

LIQUID COOLING: Corsair H100i v2
PSU: Corsair AX 860 Modular

 

HDD 8TB STORAGE

ss1.jpg

ss2.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, NiNJAWALK said:

HI guys i would like to desperately ask You for help. I have been having issues with this game regardless very decent specs. Multiple rebooting used to be the solution for last couple of days but it seems to no longer work . Whenever i launch the game, the black screen with BLUEHOLE logo loads up full screen, then the window shrinks once i get to main menu. I attach a screenshot explaining it all. I have only 3 basic resolution options to chose (800*600, 1024*720, 1920*1080), besides that the game seems to work as normal, but if i get into the game, my fps is horrible and game feels veeery rough - i get like 19 fps.  The lower resolution i set, the smaller the window gets, outside of window stays unchanged and i can use desktop as normal without ALT TABBING the game although its set to full screen as you can see. Please guys, help as I am desperately trying to find a solution. 

Steps already taken:
Complete Windows reinstall
Game re-downloaded
All drivers updated
Power plan set to high performance
Deleted AMD Crimson Relive
Deleted AMD Raptr


My specs:
CPU: Intel i7 6700K SKYLAKE 4.00 GHZ
GPU: AMD MSI RADEON R9 390 series 8 GDDR5
MB: MSI z170a m5 gaming
RAM: Corsair Predator 16GB (8x2)
SSD1 System: Kingston HyperX 240 GB
SSD2 Games/Programs: Kingston HyperX 480 GB

LIQUID COOLING: Corsair H100i v2
PSU: Corsair AX 860 Modular

 

HDD 8TB STORAGE

 

What kind of driver are you using for the monitor? Check your device manager. Is the monitor using a Generic PnP Monitor driver or perhaps something else? Or are you using a TV?

Edited by Aiiiiiiiii

Share this post


Link to post
Share on other sites
1 hour ago, Aiiiiiiiii said:

What kind of driver are you using for the monitor? Check your device manager. Is the monitor using a Generic PnP Monitor driver or perhaps something else? Or are you using a TV?

It seems like this is ordinary Generic PnP Monitor driver indeed.

ss3.JPG

Share this post


Link to post
Share on other sites
14 minutes ago, NiNJAWALK said:

It seems like this is ordinary Generic PnP Monitor driver indeed.

 

That driver should be good. What are you using as monitor? Do you have multiple monitors and in what configuration are they in if you do. Have you modified the game ini's in any way? Ran the game with default ini files? Any display related launch options like forced refresh rate or something?

Share this post


Link to post
Share on other sites
1 hour ago, Aiiiiiiiii said:

That driver should be good. What are you using as monitor? Do you have multiple monitors and in what configuration are they in if you do. Have you modified the game ini's in any way? Ran the game with default ini files? Any display related launch options like forced refresh rate or something?

I do not have multiple screen setup. I use only one monitor - HP X2301 . Yes, i did modify .Ini files before (2 reinstallations ago) as part of the FPS boost guide. I have edited about three of them, but after i realized it made my game look too bad while not giving me much higher fps rate, i deleted all the .Inis hoping that it would make it go back to default settings. I have no launch options at all.

PS. Thank You for Your interest in my case.

Share this post


Link to post
Share on other sites

UPDATE!!!
 

Yesterday i DDU deleted my display driver and reinstalled it right after i wrote this post. It solved the issue for the rest of the night. I played till about 3am having no problems at all. How on earth is this possible that i haven't done any change since last night, just switched the PC off. I start it today, launch the game and the same bloody thing! Oh my god i am about to give up on this game, this is beyond any joke.

Share this post


Link to post
Share on other sites
6 hours ago, NiNJAWALK said:

I do not have multiple screen setup. I use only one monitor - HP X2301 . Yes, i did modify .Ini files before (2 reinstallations ago) as part of the FPS boost guide. I have edited about three of them, but after i realized it made my game look too bad while not giving me much higher fps rate, i deleted all the .Inis hoping that it would make it go back to default settings. I have no launch options at all.

PS. Thank You for Your interest in my case.

Hi again. Here's a paste of the resolution related settings I have in my GameUserSettings.ini. I've been playing fullscreen at 1200p. Could you check what you have in there?

bUseVSync=True
ResolutionSizeX=1920
ResolutionSizeY=1200
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1200
WindowPosX=-1
WindowPosY=-1
FullscreenMode=0
LastConfirmedFullscreenMode=1
PreferredFullscreenMode=0
Version=1001
AudioQualityLevel=0
FrameRateLimit=1000.000000
DesiredScreenWidth=1280
DesiredScreenHeight=720
LastRecommendedScreenWidth=-1.000000
LastRecommendedScreenHeight=-1.000000

 

Also are you by any chance using VSR / GPU scaling in the Radeon Settings/Display for the monitor? Is the HP X2301 reported correctly in there as Display:1? Like this

 

Share this post


Link to post
Share on other sites
3 minutes ago, NiNJAWALK said:

UPDATE!!!
 

Yesterday i DDU deleted my display driver and reinstalled it right after i wrote this post. It solved the issue for the rest of the night. I played till about 3am having no problems at all. How on earth is this possible that i haven't done any change since last night, just switched the PC off. I start it today, launch the game and the same bloody thing! Oh my god i am about to give up on this game, this is beyond any joke.

Good timing :D That is interesting. So it fixed the fullscreen issue temporarily?

Share this post


Link to post
Share on other sites
53 minutes ago, Aiiiiiiiii said:

Good timing :D That is interesting. So it fixed the fullscreen issue temporarily?

Yep. I could happily play thorough a session of DUOs with not a single problem, everything was back to normal. Today i started my pc and its the same again. Not a single update or change performed... I did just do CC cleaner and erased all the bad stuff. Didn't help. I decided to delete all the .Ini files in WindowsNoEditor folder. It partly solved the issue. The game is back in FULL SCREEN since then but i get horrible fps (20-40) and i still have only 3 resolution options to chose... Also i realized that rolling back the display driver solves the issue entirely, but when i get into cities the textures flash white and its unplayable (but fps rate is pretty high and smooth).

Share this post


Link to post
Share on other sites
1 hour ago, Aiiiiiiiii said:

Hi again. Here's a paste of the resolution related settings I have in my GameUserSettings.ini. I've been playing fullscreen at 1200p. Could you check what you have in there?

bUseVSync=True
ResolutionSizeX=1920
ResolutionSizeY=1200
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1200
WindowPosX=-1
WindowPosY=-1
FullscreenMode=0
LastConfirmedFullscreenMode=1
PreferredFullscreenMode=0
Version=1001
AudioQualityLevel=0
FrameRateLimit=1000.000000
DesiredScreenWidth=1280
DesiredScreenHeight=720
LastRecommendedScreenWidth=-1.000000
LastRecommendedScreenHeight=-1.000000

 

Also are you by any chance using VSR / GPU scaling in the Radeon Settings/Display for the monitor? Is the HP X2301 reported correctly in there as Display:1? Like this

The only difference between Your settings and mine is vUseVsync, which is in my case =FALSE . No, I don't use GPU scaling at all and it seems to be picking up the right monitor. Have a look Yourself.

What version of display driver do You have installed ? Is Your card MSI r9 390 series too ?

 

ss4.JPG

Share this post


Link to post
Share on other sites

@NiNJAWALK I use 17.4.2 on an r9 290 so basically the same card. I have not accepted the terms for Wattman so it would not run. These are the settings i've been running the game with. Not sure if having Shader Cache On or AMD optimized is the best way to go, but since I haven't had any major issues I've just kept it On.

 

If you have not done so already, try untapping the 'Enable the Steam Overlay while in-game' option in the steam properties of the game. Some people have had framerate issues with it on so might as well try. On a side note, I also have not upgraded to Windows 10 Creators Update.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×