Jump to content
Tom 7

Bug: Game starts in wrong resolution

Recommended Posts

I've configured the game to use 2560x1600, fullscreen (not windowed), which is the native resolution of my monitor. Every time I start the game, it is actually in a much lower resolution, maybe 1280x800. I have to go into "Settings", make some trivial change (like bump the brightness up one dot) and hit "OK". Then it switches to the right resolution. In all cases the setting shows 2560x1600, so it's not like it's changing my setting, it's just not honoring it.

 

v2.4.22, 15 July 2017. Normal, not test server.

Windows 7 64-bit, 64 GB Ram, single GeForce 1080. Launching from the desktop icon (steam://rungameid/578080), no command-line options or other funny business.

Share this post


Link to post
Share on other sites
56 minutes ago, Tom 7 said:

I've configured the game to use 2560x1600, fullscreen (not windowed), which is the native resolution of my monitor. Every time I start the game, it is actually in a much lower resolution, maybe 1280x800. I have to go into "Settings", make some trivial change (like bump the brightness up one dot) and hit "OK". Then it switches to the right resolution. In all cases the setting shows 2560x1600, so it's not like it's changing my setting, it's just not honoring it.

 

v2.4.22, 15 July 2017. Normal, not test server.

Windows 7 64-bit, 64 GB Ram, single GeForce 1080. Launching from the desktop icon (steam://rungameid/578080), no command-line options or other funny business.

Have you tried setting the resolution in the .ini file then making that read only? 

Share this post


Link to post
Share on other sites

Having exactly this problem right now. My TV is a 4K Samsung. I want to play the game in fullscreen 3840x2160. I can set everything in the menu settings correctly and play the game.

Exiting the game and starting it up again, sets the resolution everytime back to 1920x1080. In the menu settings is still the 3840x2160 value visible and active. So when I change for example Anti-Alias from Ultra to High and apply the settings, the 4K resolution is working again. Works the same way, when switching to another resolution and back to 4K.

Setting the desired resolution in the .ini file does not fix it. Read only does not fix it. I have to manually reapply the settings each time after starting the game.

So, just a minor bug - but would be nice if there is a workaround or maybe a fix.

Share this post


Link to post
Share on other sites

Date Seen:
August 3rd (since I started playing the game)

Server: 
Live and Testserver

Error Message:
- none, resolution not properly active

Other Information: Exiting the game and starting it up again, sets the resolution everytime back to 1920x1080. In the menu settings is still the 3840x2160 value visible and active. So when I change for example Anti-Alias from Ultra to High and apply the settings, the 4K resolution is working again. Works the same way, when switching to another resolution and back to 4K.

Troubleshooting Attempted:

Setting the desired resolution in the .ini file does not fix it. Read only does not fix it. I have to manually reapply the settings in the game menu each time after starting the game.

Launch Options:
- none // starting directly out of Steam or using BigPictureMode behaves the same

System Specifications:
Operating System: Win10 Pro 64bit
Graphics Card: Nvidia GTX 1060 6GB
CPU: Intel i5 4690K @4,4Ghz
Ram:16GB DDR (1600Mhz)

(sorry, couldn't edit the previous post anymore)

Edited by Tepnox

Share this post


Link to post
Share on other sites

Did you change all of the following to your resolution in .ini file?
ResolutionSizeX=1920
ResolutionSizeY=1080
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1080
DesiredScreenWidth=1920
DesiredScreenHeight=1080

Share this post


Link to post
Share on other sites

same, i set up a 16:10  1792x1080 res in both nvidia control panel and in ini file. resolution shows up in game. i can play it fine. but when i exit the game and start again, it resets to my native res (1920x1080)

 

setting ini file to read only doesnt do anything. it affects any  custom resolution that is not shown in game  menu

 

i even tried forcing cusom res it via geforce experience, no deal

 

this bug is 100% reproducible. set up a new custom res that is not in menu or 16:9, and exit and start game, and boom, you are back to default res.

 

 

Edited by FelixAustead

Share this post


Link to post
Share on other sites
On 8.8.2017 at 10:40 PM, r0ck7ane said:

Did you change all of the following to your resolution in .ini file?
ResolutionSizeX=1920
ResolutionSizeY=1080
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1080
DesiredScreenWidth=1920
DesiredScreenHeight=1080

Yes, changed every of these parameters to my desired 4K-Resolution 3840x2160. The game simply ignores it.

But I figured out, the intro movie, thats plays before the main-menu, is in 4K - after the movie is done, the resolution switches back to 1920x1080. So it seems like, some hooked event after the intro-movie resets the parameters or something like that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×