Jump to content
FightMeIRL

Can no longer change keybindings under control panel

Recommended Posts

Bmorebuilt    0

I change my controller settings, every time I change it doesn't work correctly in game.  My reload is never correct character leans instead.  I can't play the game because I never have a reload button which means I can't use weapons

Share this post


Link to post
Share on other sites
joedog62    0
On 3/24/2017 at 0:33 PM, Hawkinz said:

Great! 

Very glad to hear its fixed for you :) 

Thank you for updating us.

 

On 3/24/2017 at 2:07 AM, Hawkinz said:

Hey mate,

Hold the windows key then hit R to open the run dialog, type in %appdata%

It'll open a folder in windows explorer, up the top on the address bar click AppData as seen in the image below.

6vxDYpF.png

Now on the right hand side, search for Tslgame as seen below and open the tslgame folder:

5VJyZ0Y.png

Now you need to click through a few folders, Saved, Config and then open the WindowsNoEditor folder where you should be able to locate GameUserSettings.ini as seen below:

JyAVYoJ.png

Delete the file and then relaunch the game and you should be good to go!

@dalebass @dantedel @Tended30 @alex.higginbottom

put this on the front like all the bugs to fix it. took me forever to find this in the forumz

Share this post


Link to post
Share on other sites
Yukonashi    0

What button are your reload on after u have changed it?

Normally reload is on R and lean right is on E and left is Q.

Share this post


Link to post
Share on other sites
1ejordan    0

Yesterday I plugged in my xbox controller to my pc.  I changed the "jump" control and "sprint" control to buttons on my xbox controller.  Since then every time I try to change the "Jump" control button back to [space bar] and the "sprint" control button back to [left shift] it won't apply the changes.  I have asked it to change back to default settings and it still hasn't changed back.  

 

Right now I'm stuck playing without the ability run or jump.

Share this post


Link to post
Share on other sites
Beefsticks    0

I am an EDSF gamer - old school, since before EA wrecked FPS 'gaming keyboard' layouts with WSAD.

 

Anyway, I cannot use the F key to move right no matter what I do with my layout now. This didn't happen pre-update.

 

Please fix the key functionalities!

Share this post


Link to post
Share on other sites

So I change almost all the controls when I play games... I play with my movement keys moved over one so I play esdf instead of wasd... my problem is that the f key stays set to interact no matter what you set it to in the control page in options... thank you for reading this, hope it gets fixed soon because I love this game

Share this post


Link to post
Share on other sites

Not really helpful but it's cool to hear somebody else is still using esdf...  Kind of a lost art...  I never played that far back but my dad did so I grew up playing esdf on my dad's computer...  out of curiocity would you send me what controls you use for pretty common stuff like gadgets, primary, secondary, interact... would love to hear from you... Email: bossebosid@gmail.com

Share this post


Link to post
Share on other sites

Hey update...  if you change all your controls in game then edit the config file C:\Users\USERNAME\AppData\Local\TslGame\Saved\Config\WindowsNoEditor it will work

 

Share this post


Link to post
Share on other sites
Beefsticks    0

Was wondering about a cfg file or something... thanks... was just replying to your email, but here:

Hey... for PUBG my binds weren't optimal yet, but they were:

EDSF - Movement
G - Voice Chat
V - Toggle Duck
C - Camera
Z - Prone
X - Holster
W - Interact
Q/T -  Lean/Peek
R - Reload


The rest is about the same. I aim to shift all the movement over to EDSF since you gain reach of 3 extra keybinds on the left side... 9 total with EDSF instead of just 6 total with WSAD. In other games A has always been my melee key, so for now it doesn't do anything. I should have A be activate instead of W so peeking is easier. Could always push reload to T, and have W/R for easier peek access.
 

 

Share this post


Link to post
Share on other sites
Beefsticks    0

Oh and I don't toggle mute voice chat cause it broke my audio last time... bind it wherever lol

Share this post


Link to post
Share on other sites
Posted (edited)

just remove F from the interact that should do the trick

G: Primary

A: Sidearm

5: Secondary

4: Lean right

Q: Lean left

Middle mouse: Interact

Space: ADS

RMouse: Jump

Mouse4/bottom side button: sprint

mouse5/top side button: toggle crouch

V: Toggle Prone

ESDF movement of corse

 

Also the move left is movement right Scale -1

Edited by TeamBestKorea

Share this post


Link to post
Share on other sites

I hooked a controller up and changed my key binds to the controller and i didn't like the feel of it so i tried changing my key binds back to the keyboard and now the binds will not apply and im not able to play unless its with the controller.

Share this post


Link to post
Share on other sites
dkas    0
Posted (edited)
5 hours ago, Beefsticks said:

So far yes. It unbound the S key next and was goofy but setting it again worked

 

5 hours ago, TeamBestKorea said:

Awesome

Have you guys solved your problem? I can't really understand how can I rebind F to move right.

Edited by dkas

Share this post


Link to post
Share on other sites
dkas    0

Fixed it!

In GameUserSettings.ini just rebind Gamepad_FaceButton_Left to whatever you want then it will work.

Share this post


Link to post
Share on other sites
22 hours ago, NRMedicGamer said:

I hooked a controller up and changed my key binds to the controller and i didn't like the feel of it so i tried changing my key binds back to the keyboard and now the binds will not apply and im not able to play unless its with the controller.

Delete GameUserSettings.ini, launch the game to get a new file and you will be able to adjust them again. 

Share this post


Link to post
Share on other sites

Hello I'm having control figuration problems its not applying to what i'm setting it to 

i uninstalled/reinstalled  it to see if what would help but nothing has not changed 

2017-07-08_124120202.png

Share this post


Link to post
Share on other sites
Infected    0

When I try to set E as my key to interact in the game and tab to open my inventory the game wont let me apply the changes. It lets me press the apply but wont apply I press the apply button but it does nothing. If anyone else gets this glitch or bug please help.

Share this post


Link to post
Share on other sites
KICKIN    0

Hey all. I've been playing PUBG for about 2.5 months now. I'm having the issue where peek left and right are not working. I've tried default bindings for everything (reset to default), deleted the GameUserSettings.ini file, and even uninstalled/reinstalled the game without any luck.

They did work until about 3 weeks ago then it just stopped. At that point, I had them bound to my mouse. Now I'm just trying to bind them to anything (say X and Z) on my keyboard. All other bindings work just fine. I can even change other keys to something else and they work fine. Peek does not respond to anything that I set it to for some reason.

Any suggestions or other tips?

Share this post


Link to post
Share on other sites
J_5_k    0

I use my mouse with my left hand. I've re-bound my keys centered around IJKL for movement. Prior to a recent patch (it's been about 3-4 weeks since I last played), I had bound the 'o' key to lean right successfully. Today when I tried to play, the 'o' key insists on opening the game settings menu. I've triple checked my mappings but as far as I can tell the 'o' key is definitely bound to lean right, but still opens the settings menu.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×